This plugin hasn’t been tested with the latest three major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Gravity Forms Mail Poet Add-on

Description

Create Mail Poet Newsletter subscribers from Gravity Form entires.

Please note: at this time there are no plans to continue support for Mailpoet 3.0

Requires Gravity Forms version 1.9.16 or higher.

Thanks to Dave at Deckerweb – http://deckerweb.de – for i18n enhancements and German translation

Installation

  1. Install as a regular WordPress plugin
  2. Create a form with the appropriate fields via Gravity Forms
  3. Setup Mail Poet Newsletters with one or many lists
  4. Navigate to a form then select MailPoet under Settings and setup your feeds

Reviews

3 September 2016
Awesome. Great to find something that just works without any messing about. Perfect, thanks!
Read all 6 reviews

Contributors & Developers

“Gravity Forms Mail Poet Add-on” is open source software. The following people have contributed to this plugin.

Contributors

Change log

2.0.1

  • Fix warning

2.0

  • Make use of the GFFeedAddOn class

1.4.1

  • Fix static warnings

1.4

  • Rename Wysija to MailPoet

1.3.1

  • Fix for updating other plugins

1.3

  • jQuery fix for GF 1.7.7 tooltips
  • Cleaned up warnings

1.2

  • i18n enhancements, added German translations from Deckerweb

1.1

  • Change Gravity Forms required version

1.0

  • Initial release