Starboard Suite Reservation Calendars

Description

Embed booking calendars easily using shortcodes. Learn more about the Starboard Suite reservation system at starboardsuite.com.

Includes shortcodes for embedded calendars ([starboard-suite-embedded]) and buttons that open a booking lightbox ([starboard-suite-lightbox]).

For more examples and available options, please visit https://support.starboardsuite.com/integrating-with-your-website/advanced-using-our-wordpress-plugin.

Installation

From the WordPress plugin directory (recommended):

  1. Navigate to Plugins > Add New in your WordPress Dashboard
  2. Search for “Starboard Suite”
  3. Click Install on the “Starboard Suite Reservation Calendar” plugin
  4. Activate the plugin

By direct upload:

  1. Download the plugin and unzip it.
  2. Upload the starboard-suite folder to your /wp-content/plugins/ directory
  3. Activate the plugin through the ‘Plugins’ menu in WordPress

Then

  1. Go the Starboard Suite tab in the WordPress Dashboard and add your subdomain.
  2. Use the [starboard-suite-embedded] for embedded calendars and [starboard-suite-lightbox][/starboard-suite-lightbox] shortcodes in your posts and pages.

Reviews

There are no reviews for this plugin.

Contributors and Developers

“Starboard Suite Reservation Calendars” is open source software. The following people have contributed to this plugin.

Contributors

Change Log

2.4

  • Verified compatibility with WordPress 5.6. No plugin changes necessary.

2.3

  • Verified compatibility with WordPress 5.5. No plugin changes necessary.

2.2

2.3

  • Added gift-certificate support to short tags.

2.2

  • Improved WordPress operability.

2.1

  • Improved WordPress version detection.

2.0

  • Added the ability to use tour_type_id and departure_location_id with [starboard-suite-embedded] shortcode.

1.0

  • Verified compatibility with WordPress 5.4. No plugin changes necessary.

1.0

  • Verified compatibility with WordPress 5.3. No plugin changes necessary.

1.0

  • Verified compatibility with WordPress 5.2. No plugin changes necessary.

1.0

  • Verified compatibility with WordPress 5.1. No plugin changes necessary.

1.0

  • Initial public implementation